Welcome. Get your technical questions answered and offer your help too!!!

Use EcoCash to buy NetOne & Telecel airtime online. Tap here
advertisement
advertisement
381 views
by Guru (88.1k points)
l have been using chrome for android all along and yesterday l tried firefox after a long time. lts good except that its very slow on here. On all other sites, its good and lm sticking with it.

Is there any changes l need to do? And the other thing is the rss feed, it seems not working here.

Use EcoCash to buy NetOne & Telecel airtime online. Tap here
advertisement

5 Answers

+2 votes
by
One one, JavaScript.

The amount of third party JavaScript is responsible for very slow browsing on most mobile phones.

e.g on this site Disqus, Facebook, Twitter, Google Analytics, Ad Words. What may be easy to do roundtrip downloading AND processing is easy for a normal PC but can be hectic for a phone.

Disable Javascript and note the difference

tinm@n
by Guru (88.1k points)
there is no or l cannt find the option to do that in firefox android.
by
Do the following (exclude quotes)
1) New tab
2) Type "about:config"
3) Goto "Search Settings"
4) Type "script"
5) Look for "javascript.enabled"
6) Press "Toggle" to make it false

tinm@n
by Guru (88.1k points)
You are the best!! l can see some serious improvement after following your clear instructions.
0 votes
by new here (340 points)
Restart once and try it again.
by Guru (88.1k points)
l have restart phone and still the same....
by Expert (19.6k points)
yep its the same here,...firefox seems to take its time when browsing this site.
by Guru (26.2k points)
I use firefox its really fast, i dont think its the browser, i would think its the settings
by Guru (88.1k points)
Its a shame that firefox is so fast everywhere except here. Its also not intuitive to use like chrome. Chrome have suggestions when you are looking or writing things like tags.

I honestly believe firefox and chrome both use the same engine.
0 votes
by Guru (26.2k points)
I had that problem with my laptop whenever i shifted from wireless to wired internet. I discovered that it was a settings issue. I had my browser set to  "auto-detect proxy settings for this network"  once i changed it to "manual proxy configuration" and inputted the correct setting for that network the problem was resolved. check if your Mozil has the settings in order.... hope it helps.
by Guru (88.1k points)
l have not changed from wireless to wired, lm using my phone for browsing and sitting on the same network.

Why is it fast on all other sites l visit except here? l might be overstating but having taken yo suggestion, fin firefox for android 20, l cannt see any settings related to that.
0 votes
by Guru (88.1k points)
Problem solved; tinm@n gave the answer which worked.
0 votes
by
eh blaz....kana musinga shandise Chrome makasara!!
by Guru (88.1k points)
Kungoitawa makaro ekusada kuona zvitsva. I tested firefox and liked it for a change from chrome.
Welcome to Techzim Answers,

You can ask questions and receive answers from the Zimbabwean internet community.

If you're not sure how to proceed from here just click here and ask
...