Welcome. Get your technical questions answered and offer your help too!!!

Use EcoCash to buy NetOne & Telecel airtime online. Tap here
advertisement
advertisement
1.4k views
by
Has anyone else noticed that you can not access econet.co.zw from a Tel*one connection?  I tried a few tricks including a DNS server change but to no avail.  My other links are working perfectly fine.

Use EcoCash to buy NetOne & Telecel airtime online. Tap here
advertisement

3 Answers

0 votes
by Guru (32.5k points)
Strange... I'm on ADSL and using Google DNS 8.8.8.8, 8.8.4.4. Don't have a problem connecting to the Econet website. What DNS have you tried?
by
Hey SK  I have tried those settings and the following DNS servers 194.133.122.47 and    194.133.122.42 and finally 4.2.2.2 all yield the same results.  I am using the Echo life gateway from Huawei.  What is bizarre and why I know it is my ADSL settings / link is my Econet, ZOL, Telecel and Net One internet connections from the same machine work absolutely fine. For what its worth here is the result I get from a trace if anyone can assist in troubleshooting!  Its really not a train smash I just found this to be a very bizarre.

Tracing route to econet.co.zw [77.246.51.157]
over a maximum of 30 hops:

  1    89 ms    73 ms   136 ms  192.168.1.1
  2     *        *        *     Request timed out.
  3    96 ms    57 ms    50 ms  10.0.1.1
  4     *        *        *     Request timed out.
  5     *        *        *     Request timed out.
  6   244 ms   265 ms   242 ms  217.15.120.145
  7     *        *        *     Request timed out.
  8     *        *        *     Request timed out.
  9     *        *        *     Request timed out.
 10     *        *        *     Request timed out.
 11     *        *        *     Request timed out.
 12     *        *        *     Request timed out.
 13     *        *        *     Request timed out.
 14     *        *        *     Request timed out.
 15     *        *        *     Request timed out.
 16     *        *        *     Request timed out.
 17     *        *        *     Request timed out.
 18     *        *        *     Request timed out.
 19     *        *        *     Request timed out.
 20     *        *        *     Request timed out.
 21     *        *        *     Request timed out.
 22     *        *        *     Request timed out.
 23     *        *        *     Request timed out.
 24     *        *        *     Request timed out.
 25     *        *        *     Request timed out.
 26     *        *        *     Request timed out.
 27     *        *        *     Request timed out.
 28     *        *        *     Request timed out.
 29     *        *        *     Request timed out.
 30     *        *        *     Request timed out.

Trace complete.
by Guru (88.1k points)
Its definately econet problem because that ip address   217.15.120.145  is responding deep inside them which means its theirs.

But l think there is a problem which ping or traceroute cant solve:  https.

Have a look here;

 liquid-telecommunications-ltd.10gigabitethernet5-4.core1.lon1.he.net (216.66.86.110)  19.757 ms  20.903 ms  21.087 ms
12  P1-JHB-pos8-2-1.liquidtelecom.net (46.17.232.25)  187.353 ms  185.618 ms  185.742 ms
13  46.17.232.65 (46.17.232.65)  194.685 ms  194.876 ms  194.876 ms
14  P1-HRE-g1-1-4.liquidtelecom.net (46.17.232.74)  201.419 ms  202.253 ms  202.472 ms
15  PE1-HRE-g1-0-0.liquidtelecom.net (46.17.232.29)  203.362 ms  204.321 ms  204.733 ms
16  46.17.233.6 (46.17.233.6)  206.590 ms  206.613 ms  210.063 ms
17  217.15.120.145 (217.15.120.145)  207.154 ms  208.314 ms  197.374 ms
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

You can see that my traceroute is coming in via South Africa, so Telone involved. They get to Harare dns die followed by ping right inside Econet network.

Upon further investigating, l realised that this 217.15.120.145 address is being seen as being in London so packets are put in loop until ttl expires. Or maybe that is the internal dns for econet which the dns app is dead but the host is up.
0 votes
by Guru (88.1k points)
I think its econet problem. I tried pinging it and lm getting 20% packet loss.

Why did they decide to use secure http for browsing there site? That delays browsing because ssl have to agreed first by browser and server.

Secondly, when you ping that address, ibills.econet.co.zw is the one responding, which from the name l assume it is a billing server. Why would a billing server respond to browsing request?
I think thats why its forcing everyone to use https thinking you want to do transaction hence the need for security!

Even if l type http://www.econet.co.zw, it still reverts back https://www.econet.co.zw. ls it security or just misconfiguration?
0 votes
by Expert (11.5k points)
maybe its a network prob coz mine is ok
Welcome to Techzim Answers,

You can ask questions and receive answers from the Zimbabwean internet community.

If you're not sure how to proceed from here just click here and ask
...