Welcome. Get your technical questions answered and offer your help too!!!

Use EcoCash to buy NetOne & Telecel airtime online. Tap here
in Connectivity by

Am trying to VPN to my office network through TelOne ADSL Connection.

I VPN lots of times when working remotely and have never had problems until now - behind the TelOne ADSL Modem and internet.

It opens port
Connects using WAN Miniport(SSTP)
Verifies username and password
[[ Then fails ]]

CoId={751CE192-4E75-4FA0-B953-5694AB4528A7}: The user MYPC\MyUserName dialed a connection named VPN Connection which has failed. The error code returned on failure is 800.

Modem: CellPipe 7130 Residential Gateway.
Client: Windows 7 Home Basic
Server(no control over it): Windows Server 2008R2 Well configured by our infrastructure genius

What I have tried:
- Disabled the firewall
- Advice from the following:
Connects using WAN Miniport(SSTP)

What I read:
- The modem may need a firmware update
- Modem has known issues with VPN


Use EcoCash to buy NetOne & Telecel airtime online. Tap here

4 Answers

0 votes
by Expert (17.4k points)
if your router is old and uses old firmware this error might come up.
if your remote router has blocked port 1723 & GRE Protocol 47 it might also give error 800.

From your adsl try and #telnet yourpublicipforvpn 1723 & check your routers working/running config and see if GRE Protocol 47 is enabled.

DDoS attacks can asls cause such error to come up. Are you the one who manages the routers & switches of  your remote VPN network?
Hi Shepherd.

Thanks for the info. I ran the telnet command as advised and got a "connection to host was lost" message. No idea if this relates to speed(ADSL basic - $30)

As mentioned, I have no control over the VPN server. We have a resident infrastructure guy who deals with that.

We VPN all the time from different environments *nix, Mac and Windows... no issues. I believe it is well configured and am convinced the issue exists on
- my current notebook
- the ADSL modem
- OR/AND the ISP connection

I read in one of those links that some ISPs may block VPN traffic.

No DDoS definitely.

Am still hoping for a solution. But have given up for now as my short visit has come to an end. Perhaps I need a new router as advised in one of those links.

Thanks though
by Expert (17.4k points)
Some ISP's might block smtp traffic because of their policies on spam but blocking VPN traffic is anti business to both the ISP & customer. However the next step is to do traceroute. Run tracert yourpublicip from the windows cli, if you're on *nix like OS then run tracepath yourpublicip or if it times out run pathping yourpublicip to vpn server. post the results then we can analyse these together. if tracert resolves and reaches your vpn server then it's a misconfiguration of the firewall your end or the vpn sever's end.

good luck
0 votes
by Guru (88.1k points)
I think you have done your homework thorough. What l can confirm to you is that TelOne does actually use Alcatel Lucent gear for adsl.

My advice is to take the modem and have them update the firmware for you.
Will try next time.

Was hoping at least someone had tried to VPN through the TelOne ADSL link.

Thanks McD!
0 votes
by Guru (57.6k points)
telone don't block VPN - i used to use it all the time - its likely the speed and latency of the connection causing issues, or possible the remote end not had the correct firewall ports opened/forwarded to the VPN server

i used to experience drops and fails all the time on telone, there connection to me wasnt stable enough during office hours to maintain a vpn connection for long periods of time (even on platinum)

the passthrough stuff is likely irrelevant to you as it appears that your modem/adsl connection is on the client side and not the server side?
Thanks for the insight, Anthony. I think since you have actually experienced it, I feel better answered.

I had suspected latency to be an issue and also read somewhere that VPN works best on a low latency and high bandwidth connection due to its security handshake process.

I gave up after attempting several times during my 2 days in Zim.

The ADSL connection is claimed to be 256kbps for basic($30). I imagine with the better packages, I wouldve had a better chance.

I would mark yours as an answer.
by Guru (57.6k points)
i'm not sure how telone shape there connection for the lower packages (i suspect its something along the lines of bigger packages get bigger priority)

but traceroute from your telone connection to the office vpn server, if at any point the connection leaves the country that will explain your issues - telone is massively oversold in my opinion and they dont have enough capacity to deal with peak traffic during the day hence the latency issues and connectivity issues

you will likely note that Most local connections leave the country at some point - its just telone's lack of peering with local providers and poor routing
0 votes
by new here (160 points)
i am also having the same problem, i can vpn from different networks locally e.g liquid and telone leased line but no success using telone adsl. Lots of people are using the service but with out a vpn connection it becomes difficult to work. So it is definately a problam with the settings at the ISP end because i am using a new huawei router to connect to them and i still have the same problem
Good insight in helping troubleshoot this issue. So this rules out the modem as an point of failure... unless both have issues(for which I am highly doubtful)

Am back in Zim now though I have no VPN requirements.

Its unfortunate TelOne's Tech Support is in the stone age, stuck somewhere in the 90's style of support. Non-responsive and bureaucratic!
by new here (160 points)
i have found round the whole vpn adsl issue, firstly i take it you are connecting to the vpn using pptp, it is know issue not just with telone but worldwide. It caused by ISP not route gre protocol properly, you have to use a different connection. pptp mostly works using tcp you can use a connectionless(udp) vpn.
Welcome to Techzim Answers,

You can ask questions and receive answers from the Zimbabwean internet community.

If you're not sure how to proceed from here just click here and ask